atom feed17 messages in org.apache.tapestry.usersRe: Tapestry 5.2.1 upgrade woes
FromSent OnAttachments
P.St...@albourne.comSep 22, 2010 8:12 am 
Thiago H. de Paula FigueiredoSep 22, 2010 8:18 am 
P.St...@albourne.comSep 22, 2010 8:25 am 
P.St...@albourne.comSep 23, 2010 1:05 am 
Zubair NuamaanOct 18, 2010 7:31 am 
Vangel V. AjanovskiOct 18, 2010 8:00 am 
Inge SolvollOct 19, 2010 5:24 am 
Vangel V. AjanovskiOct 19, 2010 6:07 am 
Howard Lewis ShipOct 19, 2010 8:42 am 
Vangel V. AjanovskiOct 19, 2010 2:12 pm 
ppetroupFeb 9, 2011 9:08 pm 
Thiago H. de Paula FigueiredoFeb 10, 2011 2:08 am 
Alejandro ScandroliFeb 10, 2011 2:22 am 
ppetroupFeb 10, 2011 3:21 am 
ppetroupFeb 12, 2011 1:06 am 
JavichaAug 29, 2011 8:35 am 
ppetroupAug 29, 2011 10:38 am 
Subject:Re: Tapestry 5.2.1 upgrade woes
From:P.St...@albourne.com (P.St@albourne.com)
Date:Sep 23, 2010 1:05:51 am
List:org.apache.tapestry.users

Hi,

To follow up on this issue, after I trawled through every module removing any
dated references I still could not get rid of the error, but after much toil
found the problem, which was with transitive dependencies from chenillekit, I
tried upgrading the library, but still no luck... is chenillekit compatible with
5.2.1 yet? Am I referencing the correct repo? I was already using 1.2.0
production version, I tried to move to a snapshot, but the info on the site,
found here: http://www.chenillekit.org/mvnrepo.html points to an inactive
snapshot repo, I tried
https://nexus.codehaus.org/content/repositories/snapshots/org/chenillekit/chenillekit-tapestry/1.3.0-SNAPSHOT/
but there are also issues there, eventually I had to remove chennelkit
temporarily and it now runs, but unfortunately I can't complete my upgrade
without it.

Please let me know If there is a version / repo out there compatible with 5.2.1,
if there isn't then I am forced to roll back once again.

Thanks, Peter

----- Original Message ----- From: "P Stavrinides" <P.St@albourne.com> To: "Tapestry users" <use@tapestry.apache.org> Sent: Wednesday, 22 September, 2010 18:26:11 GMT +02:00 Athens, Beirut,
Bucharest, Istanbul Subject: Re: Tapestry 5.2.1 upgrade woes

Indeed, my bad, I do combine a few maven modules that use Tapestry IoC, and I
simply missed a spot.

Thanks Thiago, Peter

----- Original Message ----- From: "Thiago H. de Paula Figueiredo" <thia@gmail.com> To: "Tapestry users" <use@tapestry.apache.org> Sent: Wednesday, 22 September, 2010 18:19:06 GMT +02:00 Athens, Beirut,
Bucharest, Istanbul Subject: Re: Tapestry 5.2.1 upgrade woes

On Wed, 22 Sep 2010 12:13:11 -0300, <P.St@albourne.com> wrote:

Hi,

Hi!

java.lang.NoClassDefFoundError: org/apache/tapestry5/internal/services/RequestPathOptimizer

You seem to have two versions of Tapestry in the classpath at the same time.